Esta madrugada, la version de PHP fue actualizada de PHP5.3 a PHP5.4 de forma automática através del panel de control Plesk. Esta actualización sucedió sin que nosotros fueramos informado de ello y nos tomó por sorpresa, ya que normalmente somos nosotros quienes controlamos las actualizaciones que deseamos aplicar en los servidores.

Como consecuencia de esta actualización algunos sitios web presentaban errores de visualización (error 500). Debido principalmente a que muchas directivas de configuración de PHP ya no existen en la versión 5.4, por ejemplo: variables globales, modo seguro, comillas mágicas, entre otras (lista oficial: http://www.php.net/manual/en/migration54.ini.php)

La primera medida que tomamos fue cambiar todos los sitios de modo FastCGI a “Módulo de Apache”, y desde entonces un gran porcentajes de los dominios caidos volvieron a la normalidad. Esperamos que esta medida sea temporal a regresar a FastCGI ya que es un modo más rápido y seguro. Mientras tanto, tenga en cuenta que operando en modo “Apache” algunos sitios web podrían requerir aplicar permisos de escritura a ciertas carpetas donde requiera crear o subir contenidos a través de la Web. Estos permisos, conocidos como chmod 777 pueden ser fácilmente aplicables utilizando su cliente FTP.

Así mismo invitamos a los clientes que operen con PHP a revisar sus scripts a fin de hacerles compatibles con PHP5.4. Este es un paso que iba a suceder de cualquier modo ya que PHP debía ser actualizado, pero tristemente sucedió antes de que nosotros pudiesémos avisar a todos nuestos clientes.

Una buena forma de revisar los scripts es activando la visualización de errores de PHP:

error_reporting(E_ALL);
ini_set('display_errors', '1');

Lamentamos mucho lo sucedido, estamos trabajando para tratar de ajustar las configuraciones lo mejor posible.

Actualización (03-ago):
En vista de que el actual webmail conocido como ATMAIL, dejó de funcionar tras no ser aparentemente compatible con PHP5.4, lo hemos sustituído por HORDE, el cambio ha sido aplicado en todas las cuentas.

Hemos reactivado los dominios a modo FastCGI luego de haber aplicado las configuraciones compatibles con PHP5.4. Algunos sitios web con código no copatible con PHP5.4 o con malas prácticas de programación pudiera presentar errores, los cuales deben ser corregidos por el cliente.



viernes, Agosto 2, 2013





« Atrás